ArcticFox 170603

Discussion in 'ArcticFox Builds' started by maelstrom2001, Jun 4, 2017.

Thread Status:
Not open for further replies.
  1. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    887
    Likes Received:
    864
    [​IMG]


    English:

    restored ability to run RX200S on 2 cells;
    fixed battery level stuck in Power Bank mode;
    added screen off feature in Power Bank mode: press "-" button to dim / off display while Power Bank is on;
    added multi-click / shortcut actions:
    • Re-Read Resistance (with udpdating profile) - allows to re-read coil without unscrewing atomizer;
    • Re-Detect Atomizer - force Smart profile switch;
    removed limitation for minimal coil resistance in VW mode;
    added ability to set system wide power limit;
    added box internal resistance compensation;
    added ability to dim charging screen on timeout (0..60 s, 0 - always on);
    changeable deep sleep timeout (1..30 min);
    tank backlight control for eGrip II / Light, eVic AIO and Pico RDTA;
    temperature can be set with an accuracy of 1°С / 2°F;
    bugfixes and minor improvements.
    [​IMG]
    CAUTION: minimal supported coil resistance is 0,05 Ohm for all modes. However, we do not recommend using coils with resistance lower than 0,10 Ohm in VW mode full time. The removal of the limit will help you when you burning new coils, whose resistance will then increase. Please, remember the manufacturer's restriction, and that safety should be in the first place.


    Russian:

    восстановлена возможность работы RX200S на 2 аккумуляторах;
    исправлено зависание индикатора заряда в режиме Power Bank;
    добавлена возможность отключения экрана в режиме Power Bank: нажатие кнопки "-" затемняет / выключает дисплей при работающем Power Bank;
    добавлены мультиклики / события на сочетания кнопок:
    • Re-Read Resistance (с обновлением в профиле) - позволяет перечитать сопротивление атомайзера без его скручивания;
    • Re-Detect Atomizer - принудительное переопределение атомайзера с вызовом Smart;
    снято ограничение на минимальное сопротивление для режима вариватта;
    добавлена возможность установки глобального ограничения мощности;
    добавлена настраиваемая компенсация внутреннего сопротивления мода;
    добавлена возможность гашения экрана зарядки по таймауту (0..60 сек, 0 - отображать всегда);
    настраиваемый таймаут перехода в глубокий сон (1..30 мин);
    управление подсветкой бака для eGrip II / Light, eVic AIO и Pico RDTA;
    температура может быть установлена с точностью 1°С / 2°F;
    исправления и незначительные улучшения.
    [​IMG]
    ПРЕДУПРЕЖДЕНИЕ: минимальное поддерживаемое сопротивление - 0,05 Ом для всех режимов. Однако, мы не рекомендуем использовать атомайзеры с сопротивлением спиралей ниже 0,10 Ом в режиме вариватта продолжительное время. Снятие ограничения поможет при прожиге новых спиралей, сопротивление которых впоследствии увеличится. Пожалуйста, помните об ограничениях, установленных производителями, и не забывайте, что безопасность должна быть на первом месте.
     
  2. darkhawk

    darkhawk New Member

    Joined:
    May 17, 2017
    Messages:
    19
    Likes Received:
    3
    Thanks for the update. You guys are awesome.

    About the "added box internal resistance compensation;".
    How can you measure that?
     
  3. ReikoKitsune

    ReikoKitsune Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    624
    Likes Received:
    478
    We can measure it easily :D

    If you are asking how you can measure it, so you should have something like this

    [​IMG]

    A more crude way is to screw the atomizer and connect plus deck and minus deck via copper thick wire.
    After that you can open NToolbox - Device Monitor and see your device internal resistance + your atty resistance.
     
  4. darkhawk

    darkhawk New Member

    Joined:
    May 17, 2017
    Messages:
    19
    Likes Received:
    3
    Thanks for the reply.
    I've found a small bug.
    I was setting my Shunt Correction to 89%. (Compared to a fairly accurate LCR meter).
    When the shunt correction is set to 89% and I try to short the 510, the device monitor reads number then stops reading. If the shunt correction is set to 100%, it reads normally.
    Shunt correction set:
    [​IMG]
    Shunt correction at 100%:
    [​IMG]
     
  5. ReikoKitsune

    ReikoKitsune Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    624
    Likes Received:
    478
    It's not a bug - this is hardware limitation of the ohmmeter. Some devices can read resistance about 0.005 ohms, some - not.
     
  6. cdyseplc

    cdyseplc New Member

    Joined:
    May 20, 2017
    Messages:
    1
    Likes Received:
    0
    thank you for removing the 0.1 limit in vw mode! much needed that!
     
  7. xarcjive

    xarcjive New Member

    Joined:
    May 17, 2017
    Messages:
    25
    Likes Received:
    5
    Excellent release, thank you!
    Re-Read Resistance is very useful, should make it the default double-click function in VW mode... ;)
     
  8. River

    River New Member

    Joined:
    Jun 6, 2017
    Messages:
    1
    Likes Received:
    0
    Hey, could I get instructions on how to use the feature of running my rx200s on two cells.
    Thanks!
     
  9. ReikoKitsune

    ReikoKitsune Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    624
    Likes Received:
    478
    Hey, you need an isolated copper piece that will replace one of the batteries.
     
    #9 ReikoKitsune, Jun 6, 2017
    Last edited: Jun 6, 2017
    Cloudasaurus likes this.
  10. Ryuk359

    Ryuk359 New Member

    Joined:
    Jun 9, 2017
    Messages:
    1
    Likes Received:
    0
    A copper piece as in bridging the two terminals on the third battery post? Insulated of course being shrink wrap or the equivalent.
     
  11. Janishewskiy

    Janishewskiy Member

    Joined:
    May 17, 2017
    Messages:
    129
    Likes Received:
    19
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    Downloaded from GitHub, can not find the original post.
     
  12. kyan31

    kyan31 New Member

    Joined:
    Jun 9, 2017
    Messages:
    7
    Likes Received:
    0
    Thank you for the update! Great work :)
     
  13. gigxy

    gigxy New Member

    Joined:
    May 29, 2017
    Messages:
    9
    Likes Received:
    4
    is there something to do with the balance wires for rx200s with 2 battery ?
     
  14. Péntek András

    Péntek András New Member

    Joined:
    Jun 11, 2017
    Messages:
    1
    Likes Received:
    2
    Hi NFE team in the next update can you guys add the bypass options???
     
    MoDuL and cdyseplc like this.
  15. Fritzko

    Fritzko New Member

    Joined:
    Jun 17, 2017
    Messages:
    1
    Likes Received:
    0
    Hey there! I randomly get a "atomizer short" message when in temperature mode. Titanium and SS316L . Downgraded to 170510, problems are gone. Testet on istick pico, rx 2/3 and evic vtc mini.
     
  16. ReikoKitsune

    ReikoKitsune Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    624
    Likes Received:
    478
  17. leliott

    leliott New Member

    Joined:
    Jun 19, 2017
    Messages:
    1
    Likes Received:
    0
    hey NFE Team ! why i can't upload the latest firmware on my RX300 ?
     
  18. Janishewskiy

    Janishewskiy Member

    Joined:
    May 17, 2017
    Messages:
    129
    Likes Received:
    19
  19. leahim

    leahim New Member

    Joined:
    Jun 20, 2017
    Messages:
    1
    Likes Received:
    0
    Hi, really nice work that u do with this firmware and the constant updates, made my joyetech products much more usable, especially the profiles/auto-resistance-detect and the new deep sleep time, very nice update.

    Not sure where to post the "issue" that I found with the new foxy skin but think its best here.

    In all other skins when I use the 1w Mode when the coil is fired I see the actual wattage that is applied to the atomizer e.g.: 60W set, when fired the watts show 59.9W.

    In the new foxy skin I can see the applied watts only when I use the 0.1W increments mode, when the 1w mode is set its not showing the applied watts just the set ones.

    Maybe it's intended because the font is centred now, in the 1w mode, and the .0 is not displayed anymore like in the other skins, but it was nice to see the actual applied power.

    Same with Arcticfox Version 170610
     
    #19 leahim, Jun 20, 2017
    Last edited: Jun 20, 2017
  20. Broki

    Broki New Member

    Joined:
    Jun 20, 2017
    Messages:
    2
    Likes Received:
    0
    Hello, thank you very much for the updates and for your hard work!

    I wanted to report and confirm a big, with both the newest and the 170510 FWs. It seems to show a constantly growing live resistance. I hit the button and it starts for example at 0.25 and just keeps going and going. It makes no sense and made a new build, but it has the exact same problem. Then it has the same problem on another atty.

    Today, my experience was like this:

    Doing TC in 316L mode, each first fire button press is amazing (it hits well, as expected). Each next fire button press is weaker, and temp. protection seems to kick off much sooner. At the end it shows "artomizer short".

    Something is quite wrong and I'm sure the problem is not with my mods or tanks, or builds. Been using them for years.

    Edit: a few more details - the Cuboid could be problematic, I can't fully scratch that off. The device worked fine the previous evening, locked properly in ss316l mode. With the same profile today, the mod suddenly started showing atomizer short errors, but re-attaching the tank seemed to help. I decided to rebuild the atty before writing the post and I'm 100% sure the coils are not touching anything else but the post holes, and know the build is not problematic. But then I just couldn't get it to work properly in TC mode and noticed the real-time resistance starts building up until the mod sleeps. Upon waking up it starts from where it actually is and then builds up indefinitely. This behavior was apparent with two different tanks, at room temp, without even firing them. I just triggered the screen with the + button and watched the live res go.

    So, it's hard to say what exactly the problem is. But another user reported a very similar issue above so I thought it's not just me.

    EDIT 2: I forgot to mention that this issue occurred only on my Cuboid mod out of 3 mods. My VTwo Mini has had the 170510 release and does not show any issue of this kind. The live ohm reading there is just fine and fluctuates only a tiny bit, which is normal. My Rx200 also did not seem to have any issues with TC. I also had a conversation with another user, who confirmed the same build-up of ohms in live reading with a few of his atomizers, so it is likely not a coincidence, but a potential software bug. It is strange that it only happens on my Cuboid, I would expect the bug on the VTC mini too but it's not there for some reason.
     
    #20 Broki, Jun 20, 2017
    Last edited: Jun 21, 2017
Thread Status:
Not open for further replies.