Eleaf iStick Pico X - Waiting for device after reset...

Discussion in 'Issues' started by mixHup, Nov 17, 2020.

  1. mixHup

    mixHup New Member

    Joined:
    Oct 14, 2020
    Messages:
    4
    Likes Received:
    3
    Currently attempting to install AF on my Eleaf iStick Pico X using NFE Tools v190718 and ArcticFox 200417 with Windows 10. Unfortunately, after the device is recognized, updating from file, and selecting af_200417.bin, the NToolbox Updater stalls at "Waiting for device after reset...". My Pico X then stays shut off with a blank/black screen and I get an error stating "Device is not connected. Update process interrupted". Only after I press the "-" button, does the device seem to reboot (w/ original firmware) and the screen turns on. I've attempted to use different USB cables and plugged in the mod without a battery while holding the "-" button. Any help/assistance would be wholeheartedly appreciated.

    Additional Notes:
    When plugged in without a battery, it doesn't boot, and only depressing the "-" after it's plugged in seems to turn the device/screen on.
    As a test, when it's stalling on "Waiting for device after reset..." and the device seemingly shuts off with a black screen, I can press the "-" button again and the screen turns on, but the updater stays stalled not recognizing the device.
     
    #1 mixHup, Nov 17, 2020
    Last edited: Nov 17, 2020
  2. mixHup

    mixHup New Member

    Joined:
    Oct 14, 2020
    Messages:
    4
    Likes Received:
    3
    Issue resolved by booting into Safe Mode referenced here Manual 7.3. Apologies for the post.
     
    maelstrom2001 likes this.