[help!] Wismec RX2 21700 "Disconnect USB, USB using too much power"

Discussion in 'Issues' started by kevinsanchezify, Jul 4, 2019.

  1. kevinsanchezify

    kevinsanchezify New Member

    Joined:
    Jul 4, 2019
    Messages:
    1
    Likes Received:
    0
    I just got my RX2 dual 21700 and wanted to burn ArticFox onto it since it has been working amazingly with my Gen3 Dual. It worked well plugging it in to update settings etc as I got used to the mod and my tastes.

    For some reason, I updated my profiles and uploaded them onto my device a couple of times, and since the last time that I did this (without any apparent issues), every time I try to plug it into my computer it comes up with a red warning saying "unplug device, USB using too much power" and I hear audio crackles when the USB plug in/out sound plays.

    • NFE tools loader no longer recognises the device at all
    • The device works fine with the last loaded settings but I cannot upload or edit it on my computer anymore
    • USB connect sound plays on and off continuously
    • Tried to boot it in safe mode without batteries, the same thing happens
    • The cable and board gets quite hot after being connected
    • The same cable works perfectly fine to use Artic Fox with my Gen3 Dual

    Any suggestions?
     
  2. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,123
    Likes Received:
    1,022
    Hello!
    First, check USB connector in the box, probably 5 volts pin (or its insulator) is damaged. Compare visually with a magnifying glass the USB ports in RX2 Dual and Gen3 Dual. If you find no damages, in any way better take the box apart and check USB connector soldering, or replace it.