No PC will detect mod (usb device not recognized)

Discussion in 'Issues' started by Doeboy, Jun 22, 2022 at 6:12 PM.

  1. Doeboy

    Doeboy New Member

    Joined:
    Wednesday
    Messages:
    1
    Likes Received:
    0
    So my eleaf istick Ipower 80w is refusing to be detected by every pc I own.

    I've tried 2 different laptops, my desktop, 4 different USB C chords on all of them including the cable that came with the mod. I have ran windows update on every computer and tried updating the drivers for the USB hub's on all the computers. I have tried rebooting multiple pc's with the mod plugged in with no luck. I've tried putting the mod into safe mode and that doesn't appear to be a thing on this model.

    I've verified that the usb ports I'm using are 2.0. Every pc is on W10

    With one of my chords windows will spam USB device not recognized, with other chords it just displays that message once.

    I verified on Eleaf's website that my mod is legitimate.

    Now all of that being said, I cannot even get the Eleaf update tool to recognize the mod on any computer so I'm at a loss. It seems like the usb connections is bad somehow, am worried the mod is defective since I've swapped computers and chords all with the same issues.

    Any suggestions are widely appreciated, I'd love to be able to flash AF and try it out!

    Thanks to the people on the discord that tried to help me troubleshoot as well
     
  2. tim_buktu

    tim_buktu Active Member

    Joined:
    Jul 7, 2018
    Messages:
    104
    Likes Received:
    65
    Hi,
    were did you read that this device is supported?
    From my point of view, it is not.
    Is there software/firmware available from eleaf for that device?