[P10] ArcticFox 170808

Discussion in 'ArcticFox Builds' started by maelstrom2001, Aug 8, 2017.

Thread Status:
Not open for further replies.
  1. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    887
    Likes Received:
    864

    English:

    stock-styled DC-DC converter startup and atomizer poll for all supported boxes (should reduce the number of "Atomizer Short" errors on boxes with hardware issues);
    optimizations.
    Russian:

    старт преобразователя и опрос атомайзера в стиле оригинальных прошивок для всех поддерживаемых устройств (должно уменьшить количество ошибок "Atomizer Short" на модах с аппаратными проблемами);
    оптимизация.
     
    Zilly, xMyPa9L, joeblowma and 6 others like this.
  2. CodusSupremus

    CodusSupremus New Member

    Joined:
    Jun 23, 2017
    Messages:
    11
    Likes Received:
    2
    Working good so far on the RX300

    EDIT: Changed batteries at 8:30, now no atomizer found error again. Same build, .24 dual fused Clapton ni80, 2x24w36. Flashed back to stock and no issues.
     
    #2 CodusSupremus, Aug 8, 2017
    Last edited: Aug 9, 2017
    maelstrom2001 likes this.
  3. bla_blub123

    bla_blub123 New Member

    Joined:
    Jul 30, 2017
    Messages:
    14
    Likes Received:
    7
    flashed my RX300 and Predator´s two hours ago everything working fine (vw mode and setup just though the nfe tools) so i didn´t test much besides vaping ;).
     
    maelstrom2001 likes this.
  4. talonclaw

    talonclaw New Member

    Joined:
    Aug 5, 2017
    Messages:
    2
    Likes Received:
    1
    Will be testing in few hours...keep up the good work
     
  5. Anney

    Anney New Member

    Joined:
    Aug 7, 2017
    Messages:
    2
    Likes Received:
    1
    Work on pico25. Everything OK.
     
    maelstrom2001 likes this.
  6. joeblowma

    joeblowma Member

    Joined:
    May 17, 2017
    Messages:
    88
    Likes Received:
    61
    Predator 228 and istick pico works well... primo mini and vtwo, both lose all settings with power in this version (but fine on 170803), both at the point where updater reboots and any time I take the batteries out. Optimized out the settings! :eek:

    edit:/ notice too, predator 228 no longer self turns on when inserting batteries. pico does... odd. (just had to take the batteries out longer) Going to recheck my dowload. Download is fine, at least as far as I can tell.
    MD5: 590BD5FA83994BF7149CCFAF1048595079DE2A41
     
    #6 joeblowma, Aug 8, 2017
    Last edited: Aug 8, 2017
    Korwin and maelstrom2001 like this.
  7. 00mpollard

    00mpollard New Member

    Joined:
    Jul 29, 2017
    Messages:
    15
    Likes Received:
    10
    Working great on rx gen3!

    Thanks :)
     
    maelstrom2001 likes this.
  8. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    887
    Likes Received:
    864
    I did not change anything with the settings in this update. 4 boxes (VTwo Mini, Pico, Pico 25, Primo) updated without settings lost, battery removal does not break the settings. Would be great if you could determine the sequence (step by step) for 100% reproducing this error. Thanks.
     
  9. temper11

    temper11 New Member

    Joined:
    Jul 14, 2017
    Messages:
    21
    Likes Received:
    7
    wow! usually, when i press 4 times buttons to re-read the coil, it jumps from 0.31 to 0,76, with atomizer short. Now testing, 0.31, 0.32, 0,31, no shorts for now! YAYYYYYY <3 <3
     
    maelstrom2001 likes this.
  10. JerseyBricklayer

    JerseyBricklayer New Member

    Joined:
    Aug 9, 2017
    Messages:
    8
    Likes Received:
    0
    Using on a istick pico. All seems good except the clock. Switching from clock A to clock D seem to do nothing and it's always military time. I seem to remember having a 12h cycle one before, a few builds back.
     
  11. jny_tr

    jny_tr New Member

    Joined:
    Aug 8, 2017
    Messages:
    6
    Likes Received:
    1
    Got me rid of Atomizer Short error on Predator 228, thank you :)
     
    maelstrom2001 likes this.
  12. Reky_FR

    Reky_FR New Member

    Joined:
    Aug 4, 2017
    Messages:
    7
    Likes Received:
    1
    Works fine on :
    • Eleaf iStick Pico
    • Vaporflask Lite
    Keep going up with this great work! your firmware is like a rebirth for my boxes, THANK YOU!
     
    maelstrom2001 likes this.
  13. temper11

    temper11 New Member

    Joined:
    Jul 14, 2017
    Messages:
    21
    Likes Received:
    7
    after 12 hours, still haven't faced any atomizer short yet.
    Do we still have short protection? :D:D:D:p good work!
     
    maelstrom2001 likes this.
  14. Vavun

    Vavun New Member

    Joined:
    Aug 6, 2017
    Messages:
    27
    Likes Received:
    11
    It's easy to check :)
     
  15. JerseyBricklayer

    JerseyBricklayer New Member

    Joined:
    Aug 9, 2017
    Messages:
    8
    Likes Received:
    0
    You have the pico as well eh. Does your clock function correctly? Mine does not. Only shows 24h clock, no 12h one. Switching from clocl a to d does nothing.
     
  16. ReikoKitsune

    ReikoKitsune Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    624
    Likes Received:
    478
    12H time format is not supported by the ArcticFox firmware.
    Clock A/D means analog or digital. Small screen devices like iStick Pico can display only digital clock, because of screen size :rolleyes:
     
  17. joeblowma

    joeblowma Member

    Joined:
    May 17, 2017
    Messages:
    88
    Likes Received:
    61
    Sorry, forum didn't notify me of the reply. The only problem devices I own are Primo mini and VTwo mini. Predator and Pico aren't doing this.

    With both on 170803, here is how I reproduce settings loss 100% on either.
    1 - plug in to pc usb
    2 - open ntoolbox, and choose firmware updater
    3 - press update from file, and choose af_170808.bin
    4 - usb reconnects a couple times, it flashes, then when the box comes back on my settings are gone.
    5 - upload the backed up settings from .afc file with afc configuration and it's file/open/upload
    6 - unplug from pc, it is working normally with my settings
    7 - shut off via fire clicks
    8 - wait a minute or two
    9 - remove batteries for 5s or so, put them back, all settings are gone.
    not sure if 7&8 are needed to write the settings to flash after pc tool upload, so I did it anyway before mentioning here.

    If it was just the one device I would suspect hardware fault, but flashing back to 170803, restore settings, and do the same and nothing is lost on either. I took a copy of settings and dataflash on both devices immediately before flashing 170808 (on 170803), and again immediately after, if that helps any it is attached.

    edit:/ only one thing is common about this too, which is odd. The predator and pico both came from a local vape shop, while the primo mini and vtwo came direct from China. Don't know if that is relevant or just an odd coincidence. I can take them apart and get info off the chips if need be. The vtwo has never worked quite right so I've had it apart a few times, and put it aside when I got primo mini - I dug vtwo out to test because primo mini did this weird thing.
     

    Attached Files:

    #17 joeblowma, Aug 9, 2017
    Last edited: Aug 9, 2017
  18. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    887
    Likes Received:
    864
    @joeblowma great, thank you. Will try to reproduce on my VTwo Mini with your .dataflash and .afc (the same HW version, from FastTech). Perhaps this will help:
    1. Make backup of settings;
    2. Flash 170808;
    3. Perform dataflash reset via Firmware Updater, disconnect USB;
    4. Remove battery for about a minute;
    5. Insert battery;
    6. Connect and upload backed up settings;
    7. Wait for about 10 sec and try to remove/insert battery.
    This procedure should initialize dataflash storage from scratch, and box should not lose settings on power off.
     
    joeblowma likes this.
  19. joeblowma

    joeblowma Member

    Joined:
    May 17, 2017
    Messages:
    88
    Likes Received:
    61
    Sadly it did not help, I tried resetting dataflash before but did not remove battery, just uploaded my settings straight away. I just tried 170804 (only on primo mini this time), and no problem there either.

    edit:/ just to be clear, I tried your steps as you wrote, not just relied on "I tried that before" :)

    edit2:/ I found it was able to keep settings I made on the device between powers on 170808, so I proceeded to copy over a bunch of the settings with the PC tool but after upload it loses them again. I am using NFE-Tools-v170624-22.31, in case that may be the source of the issue.
     
    #19 joeblowma, Aug 10, 2017
    Last edited: Aug 10, 2017
  20. Reky_FR

    Reky_FR New Member

    Joined:
    Aug 4, 2017
    Messages:
    7
    Likes Received:
    1
    No idea, i don't use this functionality on the Pico (screen is too small for that to my opinion)
    But i'll check that for you in the coming days and i'll let you know ;)
     
Thread Status:
Not open for further replies.