Pico 75W - Configuration lost after battery change

Discussion in 'Issues' started by mithril, Aug 29, 2019.

  1. mithril

    mithril New Member

    Joined:
    Aug 29, 2019
    Messages:
    3
    Likes Received:
    0
    This morning when I put a battery in my Pico (I never let the battery in overnight) all my customized settings were reset.
    Only the puff counter and timer seems to have survived.
    Another strange thing, aside from the reset, is that the HW version read -0.01 when I connected to NFE Tools.

    I reflashed the firmware and restored all the settings from a backup and changed the HW ver to 1 but I have the feeling something is wrong with my device.

    What tests can I do?

    Edit: AF version was 190624
     
  2. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,670
    Likes Received:
    1,541
    Hello!
    Do not worry, nothing wrong with your device.
    Resetting to defaults was caused by incorrect data saved in non-volatile memory. This can happen when the power is turned off at the time of saving the data. I suspect the following has happened: when you put the battery in Pico and started to screw the battery cap, the box was powered and started, but after a short time the power was lost cause the cap was not screwed in completely. This "bounce" of negative contact (thru the cap) caused multiple restarts, which led to data corruption and reset to defaults.
    To prevent this issue in the future, try to screw the battery cap a bit quicker and with moderate pressing.
     
    mithril likes this.
  3. mithril

    mithril New Member

    Joined:
    Aug 29, 2019
    Messages:
    3
    Likes Received:
    0
    Thanks for the explanation.
    Can't remember if I took my sweet time screwing down the cap but I'll make sure to be quick about it from now on.