Work In Progress Public Beta: STM32 Branch

Discussion in 'Suggestions' started by maelstrom2001, Feb 24, 2020.

  1. Serguei

    Serguei New Member

    Joined:
    Sep 19, 2021
    Messages:
    8
    Likes Received:
    3
    Sorry, yesterday night on some reason the firmware was not properly updated and remained unchanged. Today I checked all stuff and download all properly. I also checked the device with 2 atomizers (0.5 and 1.0 ohm SS316 ). SEEMS PROBLEM GONE!!!! :) Thank U very, very much! Arctic Fox is the best!!!!!!
     
  2. Megamorter

    Megamorter New Member

    Joined:
    Aug 21, 2021
    Messages:
    5
    Likes Received:
    6
    Very exciting, thanks for the update! I'll load it up when I get home.
     
    maelstrom2001 likes this.
  3. Megamorter

    Megamorter New Member

    Joined:
    Aug 21, 2021
    Messages:
    5
    Likes Received:
    6
    Wow this is working beautiful, I'm actually amazed.

    Fired it at 280F, 300F, 320F and 340F for 20-30 seconds each, right after each other, and I got 0 "atomizer not found" errors. Put some concentrate in and ran it at 280, 300, and 320 for 1 minute each and again, 0 errors.

    So far, this is working perfectly and I'm very grateful. Thank you a metric ton, seriously.

    and my Rim C is newer, yeah. I bought it June 2021. I have a Pico from 2016 and I tried 10+ AF builds before one worked so it could definitely have been a hardware change causing issues with the Rim C.
     
    maelstrom2001 likes this.
  4. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,634
    Likes Received:
    1,498
    @Megamorter, @Serguei many thanks for bugreports and testing, hope this issue was fixed :)
    I bought mine more than a year ago, in September 2020, and since never checked OEM firmware, so yes, probably some modifications in hardware and firmware was made.
    Sorry for late fix, I wanted to make sure that the problem is really widespread, cause I really can't reproduce it.
     
    TinaEire and Megamorter like this.
  5. Megamorter

    Megamorter New Member

    Joined:
    Aug 21, 2021
    Messages:
    5
    Likes Received:
    6
    Any time, bud :)

    Damn, they changed quick. I'll post this on Reddit for the 2021 Rim C people, I'm sure they'd be excited.

    I absolutely appreciate all the work and effort you put in, I can wait haha no worries. The fact that you're doing working on these extra devices at all is incredible and very much appreciated.
     
    TinaEire and maelstrom2001 like this.
  6. TinaEire

    TinaEire Member

    Joined:
    Nov 10, 2018
    Messages:
    56
    Likes Received:
    33
    I discovered an awkward TC behavior:
    I tested the Rim C, Grus, vs other AF/RP mods (V200 STM32, P80, Espion), all with the same SSFC 316L Coil in a Aromamizer Supreme V3 (Single Coil deck). All were set up to 220 degrees C TC, 316L, 45W, 120% and 0,5s preheat with a 15s delay and no PI reg.
    The Grus and Rim C never reached the 220 degrees:
    TC Grus SSFC 316L no PI.JPG TC RIM C SSFC 316L no PI.JPG
    The V200 (STM32), P80 and Espion did reach the 220 degrees and the Wattage was regulated down:
    TC V200 STM32 SSFC 316L no PI.JPG TC P80 SSFC 316L no PI.JPG TC Espion SSFC 316L no PI.JPG
    Any ideas?
     
    maelstrom2001 likes this.
  7. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,634
    Likes Received:
    1,498
    Hello!
    It seems that Cold Resistance is too high.
    Try to connect the mod with cold coil to the Device Monitor, see Live Resistance chart and then set manually that approximated value to the Cold Resistance in profile and lock it.
     
    TinaEire likes this.
  8. TinaEire

    TinaEire Member

    Joined:
    Nov 10, 2018
    Messages:
    56
    Likes Received:
    33
    Thanks, I forgot that.
    Now I measured the cold resistance with a DNA250C it had 0.276. This tine I locked R in the Grus (210331), and the black RimC (delivered 1week ago) and added a RimC white (delivered ~ 3 Month ago) both Rim C 211009.
    Grus
    TC Grus SSFC 316L no PI R locked 276.JPG
    RimC black
    TC RIM C black SSFC 316L no PI R 276 .JPG
    RimC white
    TC RIM C white SSFC 316L no PI R 276 .JPG
    Now the Grus looks better, but has an awkward saw tooth in the Wattage, the newer black RimC still doesn't reach the 220 degrees and the white instantly starts to regulate the Wattage down. Now I am even more puzzled o_O:oops:
     
    #148 TinaEire, Oct 20, 2021
    Last edited: Oct 20, 2021
  9. tim_buktu

    tim_buktu Member

    Joined:
    Jul 7, 2018
    Messages:
    86
    Likes Received:
    46
    Hiya @TinaEire, you have PM also :)
    I would suggest to check the internal resistance of the devices first before comparing the loggings.
    There may be little differences in the resistances (contact resistance between 510 and attomizer as well) that can cause that. The internal resistance should be checked and can be calibrated in NToolbox.
     
    TinaEire and maelstrom2001 like this.
  10. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,634
    Likes Received:
    1,498
    True. When we transferring a profile from one box to another, we have to check and set the proper cold resistance. Even the calibration by internal resistance between boxes sometimes does not solve such issues.
     
  11. Ryan L Lynch

    Ryan L Lynch New Member

    Joined:
    Sep 7, 2021
    Messages:
    1
    Likes Received:
    0
    I'm having trouble flashing the new firmware from the 10th onto my Rim C. The firmware updater recognizes the mod code correctly (M177) but says unknown device. When trying to flash, the mod's screen goes black and stays so until removing and replacing the battery. The software also loses connection to the device while waiting for it to reset.
     
  12. Megamorter

    Megamorter New Member

    Joined:
    Aug 21, 2021
    Messages:
    5
    Likes Received:
    6
    "Need to put it into safe mode first. It's in the af install document. But basically unplug and remove battery. Hold + then plug in USB cable. Screen will be off, Then flash. It will reboot and mod will turn on"

    This should help
     
    maelstrom2001 likes this.
  13. TinaEire

    TinaEire Member

    Joined:
    Nov 10, 2018
    Messages:
    56
    Likes Received:
    33
    I had the same problem. I did put it in safe mode and tried to update it from there, but that failed too (no battery and pressed fire and + button, then connected to USB). Same result again. It flashes but gets stuck when trying to restart the RimC during the procedure.
    I was able to download the factory FW (from eleafworld.com) to flash that and then with NFTools the latest Arctic Fox version 211009 was flashable.
     
    #153 TinaEire, Oct 21, 2021
    Last edited: Oct 23, 2021
  14. alienbiker

    alienbiker New Member

    Joined:
    Oct 21, 2021
    Messages:
    1
    Likes Received:
    1
    Thanks for the updated firmware, seems to have fixed the error for me too
     
    maelstrom2001 likes this.