Second battery does not work

Discussion in 'Issues' started by VolpeArtica, Dec 8, 2020.

  1. VolpeArtica

    VolpeArtica New Member

    Joined:
    Dec 8, 2020
    Messages:
    2
    Likes Received:
    0
    Battery not recognized



    Hello everyone,

    My box mod does not turn on when one of the two Samsung INR21700-50E batteries in my possession is inserted.
    Useful info below:
    • Device name: Wismec Luxotic MF Box.
    • Device hardware version: 1.00.
    • ArcticFox version: 190624.
    I state that the two 21700 batteries are identical and arrived together about a week ago. The batteries have always been functional and both correctly recognized. The mod arrived yesterday morning and I tried it for about an hour with its original firmware, before flashing ArcticFox, but I can't say for sure if I tried both batteries with its original firmware (but for sure at least one worked correctly).
    What can it be?
    Has anyone else encountered this type of problem with ArcticFox or the Luxotic MF?

    Thank you in advance!
     
    #1 VolpeArtica, Dec 8, 2020
    Last edited: Dec 9, 2020
  2. VolpeArtica

    VolpeArtica New Member

    Joined:
    Dec 8, 2020
    Messages:
    2
    Likes Received:
    0
    SOLUTION

    Due to the insufficiently protruding positive pole contact of the Luxotic MF Box, one of my 21700s was not making proper contact. By removing part of the protective film of the battery itself (at the height of the positive pole), the battery is correctly recognized.