Wismec CB-80 рано срабатывает Battery Low

Discussion in 'Русскоязычный форум' started by Uncle_Brr, Sep 17, 2019.

  1. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Привет всем и спасибо за работу!
    Новый Wismec CB-80, новые батарейки - шоколадка и соня 5а, Лиса, от 190624.
    Гоню 50 Ватт на 0,30 Ома, фехраль.
    При заряде чуть меньше 50% выкидывает Battery Low и отказывается выдавать хоть что-то.
    ОЧЕНЬ неудобно!
    Подробную статистику, к сожалению, сейчас дать не могу - тулзы на тутошнем маке не запускаются (прошивал на чужой венде).
    Эта же батарейка на старом Сигелее 90 прекрасно парится, вплоть до 12%.
    Можно что-нибудь сделать?
    Заранее благодарен ;)
     
  2. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,158
    Likes Received:
    1,058
    Добрый день!
    Похоже, что это болезнь всех подобных модов с лючком батареи в нижней части корпуса: P80, Primo Mini и т. п.: https://nfeteam.org/forum/threads/the-best-box-supported-by-arcticfox.243/#post-1341
    Можно поискать место просадки, оно должно быть в районе этого самого лючка и пружинного контакта, и при 50 ваттах быть заметно теплее.
    И все же попробуйте запустить монитор, хотя бы под виртуальной машиной с Windows, и посмотреть, как просаживается напряжение питания при затяжке. Это и даст ответы на вопросы, и поможет при устранении плохого контакта.
     
  3. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Спасибо за ответ!
    Нет, мод совсем новый, пружины и контакты все крепкие и чистые, вероятность хардверной проблемы весьма невелика, похоже на софт.
    Монитор запустить не могу - винды тут нет, под (этим старым) маком макосная версия не запускается, вайна и виртуалки тоже нет :(
    Помнится, что ранние версии Лиса как раз боролись с такими симптомами. Разве не так?
    Понятно, что с монитором будет гораздо проще, но это - только в следующем месяце... если не победим, то буду ждать возвращения к нормальному компу ;)
     
  4. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,158
    Likes Received:
    1,058
    Вообще не показатель :D вспомните шквал Atomizer Short на eVic Primo, Predator 228 прямо из коробок.
    Так, только случаи были особые - в режиме ТК и на некоторых очень уж удивительных модах. А в последних - да, было дело с Pico S и еще парочкой моделей.
    Попробуйте приложенную сборку, возможно, что ситуация улучшится. И отпишитесь по результатам, пожалуйста - если помогло, то исправление уйдет в nightly и дальше по основной ветке.
     

    Attached Files:

    Uncle_Brr likes this.
  5. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Спасибо! Всё сделаю, но только через несколько дней (венды тут нет) - и монитор поставлю и прошивку накачу. Отпишу обязательно ;)
     
    maelstrom2001 likes this.
  6. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Привет! Накатил. Ничего не изменилось, уже на 50% имеем "Battery Low" :(
    Кстати, линуксовая версия эту прошивку не понимает - древняя говорит ;)
    Вот, что кажет монитор.
    Идеи?
     

    Attached Files:

  7. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,158
    Likes Received:
    1,058
    Идеи простые, как хозяйственное мыло.
    Существует 2 момента, когда может возникать событие Battery Low или Weak Battery:
    1. Просадка питания на входе от плохого контакта и/или старости аккумулятора.
    2. Перегрузка питания по входу при смене режима работы преобразователя с buck на boost.
    Если напряжение аккумулятора во время затяжки болтается около 2,8 вольт, судя по скриншоту, то получаем одно или оба эти события. Сборка 190919 потенциально исправляет ошибку номер 2: начиная со сборки 190315 (nightly) возможна нестабильная работа преобразователей, о которой упомянул в посте Wismec CB-80 рано срабатывает Battery Low. Итого, остается попробовать сборки ранее, чем март 2019 на тестовых нагрузках двух типов:
    • сопротивление пониже, когда подаваемое напряжение всегда ниже напряжения аккумулятора (<= 3.3 вольт, например);
    • сопротивление повыше, когда сразу включается boost, т. к. установленное выходное напряжение выше напряжения аккумулятора.
    На скриншоте не видно напряжение аккумулятора в дежурном режиме. Если предположить, что заряд отображается как 50%, то оно должно быть не менее 3,6 вольт. Падение с 3,6 до 2,8 это далеко не норма. Ситуация еще слегка усугубляется намоткой: 50 Вт для 0,3 Ом - 3,87 вольт, ни туда, ни сюда.
    Дайте на свою намотку 30 Вт, и преобразователь будет всегда в режиме buck, замерьте просадки. И дайте 60 Вт, в этом случае всегда будет boost, и также прикиньте просадку.
    По скриншоту вижу ограничение мощности в режиме boost (именно на стабильном бусте, а не переходе buck/boost), т. к. напряжение аккумулятора слишком низкое. Это тоже подтверждает либо плохой контакт, либо уставший аккумулятор.
     
  8. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Приветик и спасибо за ответ!
    Это проверялось на заряде батареи близком к >50%.
    Вот скрины на полностью заряженной новой, честной Сони 6А.
    Попробую залить что-то более раннее и отрапортую ;)
    Мне собственно важнее всего знать - это софтовая проблема или хардверная. Я бы предпочёл второе, поскольку разобрать и посмотреть проще, чем в коде ковыряться.
    UPD. Вскрыл, разобрал, посмотрел: пайки проводов нормальные (не прокалываются), провод толстый, на плате внешних непропаев нет. Собрал.
     

    Attached Files:

    #8 Uncle_Brr, Sep 26, 2019
    Last edited: Sep 26, 2019
  9. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,158
    Likes Received:
    1,058
    Чтобы исключить или подтвердить подозрения на проблемы с ArcticFox, можете поставить стоковую прошивку и посмотреть в тех же условиях на ее поведение и до скольки она выжмет аккумулятор. Правда, скорее придется ориентироваться на ощущения, т. к. сток может не отображать сброс мощности при просадках, ну и монитора не будет. Но подозрения все же на хард, очень уж неприлично просаживается питание. Полвольта при 30 Вт на понижении - это перебор.
     
  10. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Попробую не стоковую а ноябрьскую прошлого года поставить - у меня она хорошо себя зарекомендовала.
    UPD. Вскрыл, разобрал, посмотрел: пайки проводов нормальные (не прокалываются), провод толстый, на плате внешних непропаев нет. Контакты чистые, протёр ластиком и спиртом. Собрал.
     
  11. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Вот картина после разборки/чистки/сборки на прошивке 180905. Вроде как получше стало?
    (пардон, перед этим залил скрины не с тем баком) ;) сейчас правильные ;)
     

    Attached Files:

    #11 Uncle_Brr, Sep 26, 2019
    Last edited: Sep 26, 2019
  12. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,158
    Likes Received:
    1,058
    Это уже похоже на правду :) если не лень, то можете поэкспериментировать еще с прошивками, последовательно ставить более свежие. Поскольку изменений было два (переборка и смена прошивки), точно определить что именно вырулило ситуацию сказать невозможно.
     
  13. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Я конечно попробую, но теперь уже когда время будет. Основная проблема - отсутствие винды и невозможность запустить тулзы в виртуальной машине (ХЗ почему, а разбираться некогда). Знаю только одно - из всех моих девайсов только на одном (Пико Сквиз 2) стоит прошивка 2019 года, значит, когда-то я уже с ними экспериментировал, не взлетели.
    Энивей, спасибо за помощь! :)
     
  14. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Пока суть-да-дело - не подскажете мне: а что вот это за фигня??? (Пико Сквиз 2, 21700, 100%, 1 спираль, AF 190315). Работает нормально, график просто странный ;)
     

    Attached Files:

  15. maelstrom2001

    maelstrom2001 Developer
    NFE Team

    Joined:
    May 4, 2017
    Messages:
    1,158
    Likes Received:
    1,058
    А что, собственно, так озадачило? Разброс измерений напряжения с суммарной амплитудой 0,1 вольт (±0,05 вольт)? Бывает и куда хуже :D
    P. S. объяснение на самом деле простое: в режиме ожидания производится 16 измерений, и результатом является их среднее арифметическое, поэтому большого разброса не видно. При затяжке делается 3 измерения, и если все они ниже, чем Cutoff в профиле аккумулятора, то затяжка отсекается и выводится Low Battery, а сами по себе результаты никак не фильтруются - что последнее пришло, то и отдается Device Monitor.
     
    #15 maelstrom2001, Sep 28, 2019
    Last edited: Sep 28, 2019
  16. Uncle_Brr

    Uncle_Brr New Member

    Joined:
    Sep 8, 2017
    Messages:
    29
    Likes Received:
    1
    Спасибо за разъяснение.
    Собственно озадачила такая "пила". Дело в том, что ни на одном из моих девайсов (а они все, за исключением Зигеля, конечно, работают под Лисом), такого графика не бывает. Плавные изменения, изредка пики, но, чтобы такая пила вылезала - увидел в первый раз, вот и спросил ;)