wismic predator not recognized

Discussion in 'Issues' started by paulzedx636, Sep 17, 2018.

  1. paulzedx636

    paulzedx636 New Member

    Joined:
    Sep 17, 2018
    Messages:
    19
    Likes Received:
    2
    im trying to update my predator to the latest build however it is not reconized by NToolbox when im in firmware updater it just says waiting for device. ive tried different cables even a new cable my rx200 is recognized on all the cables almost instantly. i have build 171126 on the predator and i works fine yet its not recognized to update or change settings in arcticfox configuration. i really want to try to figure this out thanks for any suggestions.
     
  2. X-R4Y

    X-R4Y Active Member

    Joined:
    Aug 7, 2017
    Messages:
    193
    Likes Received:
    71
    Try safemode (see manual how to do it).
     
    paulzedx636 likes this.
  3. paulzedx636

    paulzedx636 New Member

    Joined:
    Sep 17, 2018
    Messages:
    19
    Likes Received:
    2
    ok im looking in the manual and will try to use safemode thanks for the reply.
     
  4. paulzedx636

    paulzedx636 New Member

    Joined:
    Sep 17, 2018
    Messages:
    19
    Likes Received:
    2
    i am able to go into safemode, however the predator is still not recognized by my computer or NToolbox ive also tried using the different cables that work fine on the rx200. the predator does charge from usb no problem, but its still not being recognized.
     
    #4 paulzedx636, Sep 17, 2018
    Last edited: Sep 17, 2018
  5. X-R4Y

    X-R4Y Active Member

    Joined:
    Aug 7, 2017
    Messages:
    193
    Likes Received:
    71
    Have you updated your NFE Tools to the newest version to install the newest build?
     
    paulzedx636 likes this.
  6. paulzedx636

    paulzedx636 New Member

    Joined:
    Sep 17, 2018
    Messages:
    19
    Likes Received:
    2
    yes i have updated to the newest version, i believe the problem is in the usb port on the predator because i watched some videos on how to clean the port. after that i barely got my computer to recognize it, but the connection would drop instantly. it wasnt enough for NTools to recognize it, so i may just be happy with build 171126.
     
    #6 paulzedx636, Sep 17, 2018
    Last edited: Sep 17, 2018
  7. X-R4Y

    X-R4Y Active Member

    Joined:
    Aug 7, 2017
    Messages:
    193
    Likes Received:
    71
    Use pressured air to clean the USB port. Or disassemble the mod and clean it.
     
  8. paulzedx636

    paulzedx636 New Member

    Joined:
    Sep 17, 2018
    Messages:
    19
    Likes Received:
    2
    i cleaned it first with a tiny piece of plastic and then with batteries out alcohol on small cotton thats when i started getting a connection. so i did it again with alcohol that was a bad idea because i almost bricked my mod it wouldnt turn on for some time. i then took it apart and used a hair dryer and let it sit over night and it worked again. i may just be content that the mod still works so at the moment im seaching for a small mod that supports arctic fox.